fbpx
 

Apa itu DDOS Blackhole Routing?

DDoS Blackhole Routing (terkadang disebut dengan Blackholing), adalah tindakan pencegahan untuk mengurangi serangan DDoS di mana lalu lintas jaringan dialihkan ke “Blackhole / Lubang hitam”, dan hilang. Ketika pemfilteran Blackhole diterapkan tanpa kriteria batasan khusus, lalu lintas jaringan yang baik dan berbahaya diarahkan ke Null-Route atau lubang hitam dan dikeluarkan dari jaringan. Tapi mengapa menggunakan Blackhole Routing? Lalu lintas yang tidak diinginkan yang membanjiri aliran Network dan Mesin dari media transmisi yang berbeda, sengaja dihasilkan oleh serangan DDoS.

Maksud utama dari serangan DDoS adalah untuk menguras ketersediaan sumber daya komputasi seperti bandwidth, CPU, RAM, dan lain-lain ke target jarak jauh sehingga layanan di luar batas untuk pengguna yang sah. Pengguna mungkin mengalami penggunaan bandwidth yang berlebihan, atau penggunaan CPU yang berlebihan adalah beberapa gejala khas yang terkait dengan serangan ini. Ini menciptakan kebutuhan untuk menghentikan traffic DDoS yang ditujukan ke lubang hitam sebagai tindakan balasan yang sangat baik untuk mencegah serangan semacam ini. Perutean internet blackhole didasarkan pada alamat IP sumber dan tujuan, di mana teknik yang paling umum digunakan adalah menggunakan penyaringan rute jarak jauh, memanfaatkan IP tujuan.

Bagaimana Blackhole Routing Bekerja?

Lalu lintas DDoS harus dialihkan dan dijatuhkan di dekat sumber serangan. Blackhole routing melibatkan penggunaan alamat IP sumber dan tujuan dan, seperti yang disebutkan di atas, teknik yang paling umum digunakan, menggunakan pemfilteran rute jarak jauh. Misalnya, serangan DDoS dimulai pada server web yang menyimpan alamat IP 172.12.0.2.

Saat pelanggan meminta ISP untuk memfilter DDoS yang sedang berjalan, rute statis ke alamat IP target 172.12.0.1/32 akan dibuat, yang mengarah ke interface null atau tidak ada. Rute statis didistribusikan ke sesi iBGP dari mesin pemicu ke border router tetapi dengan alamat IP hop yang diperbarui ke 192.0.2.1. Akibatnya, semua lalu lintas jaringan diarahkan ke alamat IP ini, sehingga dihilangkan dengan null-route di border router. Saat serangan DDoS selesai, rute statis 172.12.0.2 dihapus dari mesin yang dipicu dan ditarik dari sesi IBGP.

Bagaimana Blackhole Routing dapat membantu Anda?

Tidak diragukan lagi, Anda dapat mengarahkan semua lalu lintas yang tidak diinginkan ke lubang hitam untuk membuangnya melalui lubang hitam di mana tidak ada titik kembali.

Jika Anda mengingat, pada tahun 2008 YouTube turun selama berjam-jam pada suatu hari berkat penggunaan Blackhole Routing oleh Telkom Pakistan. Ini terjadi setelah Kementerian Komunikasi Pakistan mengirimkan perintah agar YouTube diblokir secara nasional sebagai tanggapan atas video YouTube yang berisi kartun Belanda yang menggambarkan Nabi Muhammad. Layanan telekomunikasi milik pemerintah Pakistan menanggapi perintah ini dengan solusi perutean lubang hitam, tetapi solusi mereka menciptakan efek samping yang tidak terduga.

Blackhole Routing dapat membantu menghentikan semua lalu lintas berbahaya jika terjadi serangan, misalnya, DDoS atau serangan worm di mana Blackhole Routing berimprovisasi sebagai solusi terbaik untuk mengurangi waktu henti. Selain itu, berbeda dengan ACL (Access Control List), Anda dapat menggunakan solusi alternatif ini karena routing bekerja dengan cara penerusan dari router, Anda dapat menggunakan Blackhole Routing yang menenggelamkan lalu lintas yang sama dengan keuntungan untuk mengurangi dampak kinerja pada router itu sendiri.

Mengapa menggunakan Blackhole Routing sebagai biaya peluang untuk ACL terutama karena ACL membutuhkan daya pemrosesan yang lebih tinggi pada urutan operasi cisco IOS, ACL akan melayani cara yang sama seperti perutean lubang hitam tetapi akan membutuhkan lebih banyak fitur untuk melakukannya.

Bagaimana Herza.ID mengurangi resiko DDoS dengan Blackhole Routing?

Pada sistem Network Herza.ID, kami telah mengimplementasikan Auto-Trigger Blackhole Routing atas setiap aktivitas yang mencurigakan. Dari Border Router kami mengirimkan Traffic Flow ke Server FastNetMon kami yang akan memproses seluruh aktivitas di jaringan kami. Dan ketiga suatu aktivitas mencurigakan men-trigger alarm, maka Server FastNetMon akan mengirimkan proses iBGP untuk melakukan Blackhole menggunakan Community Blackhole system.

Salah satu contoh, Anda bisa melihat di graphic dibawah ini, dimana garis merah mengindikasikan terjadi trigger alarm atas suatu aktivitas yang mencurigakan, dan server FNM kami dengan sigap mengirimkan instruksi ke Border Router untuk melakukan Blackhole.

Apa itu Internet Exchange Point?

Internet Exchange Point (IXP) adalah lokasi fisik tempat perusahaan infrastruktur Internet seperti Penyedia Layanan Internet (ISP) dan CDN (Content Delivery Network) terhubung satu sama lain. Lokasi ini berada di sisi pada jaringan yang berbeda, dan memungkinkan penyedia jaringan untuk berbagi transit di luar jaringan mereka sendiri. Dengan hadir di dalam satu lokasi IXP, perusahaan dapat mempersingkat jalur mereka ke transit yang datang dari jaringan lain yang berpartisipasi pada IXP tersebut, sehingga mengurangi latensi, meningkatkan waktu lalu lintas data, dan berpotensi mengurangi biaya.

Bagaimana cara kerja Internet Exchange Point?

Pada intinya, IXP adalah satu atau lebih lokasi fisik yang berisi switch jaringan yang merutekan lalu lintas antara jaringan anggota yang berbeda. Melalui berbagai metode, jaringan ini berbagi biaya pemeliharaan infrastruktur fisik dan layanan terkait. Mirip dengan bagaimana biaya timbul ketika pengiriman kargo melalui lokasi pihak ketiga seperti melalui Terusan Panama, ketika lalu lintas ditransfer melalui jaringan yang berbeda, terkadang jaringan tersebut mengenakan biaya untuk pengiriman tersebut. Untuk menghindari biaya ini dan kekurangan lainnya yang terkait dengan pengiriman lalu lintas mereka melalui jaringan pihak ketiga, perusahaan anggota terhubung satu sama lain melalui IXP untuk mengurangi biaya dan mengurangi latensi.

Apa itu IXP

IXP adalah Layer 2 LAN yang besar besar (dari model jaringan OSI) yang dibangun dengan satu atau banyak switch Ethernet yang saling terhubung bersama di satu atau lebih bangunan fisik. Sebuah IXP tidak berbeda dalam konsep dasar dengan jaringan rumah, dengan satu-satunya perbedaan nyata adalah switchnya. IXP dapat berkisar dari 100s Megabit / detik hingga banyak Terabit / detik untuk lalu lintas yang dipertukarkan. Terlepas dari ukurannya, tujuan utamanya adalah memastikan bahwa banyak router jaringan terhubung bersama dengan bersih dan efisien. Sebagai perbandingan, di rumah seseorang biasanya hanya memiliki satu router dan banyak komputer atau perangkat seluler.

Selama dua puluh tahun terakhir, telah terjadi perluasan besar-besaran dalam interkoneksi jaringan, yang sejalan dengan perluasan besar-besaran Internet global. Perluasan ini mencakup fasilitas pusat data baru yang sedang dikembangkan untuk peralatan jaringan rumah. Beberapa dari pusat data tersebut telah menarik sejumlah besar jaringan, sebagian besar karena titik pertukaran Internet yang berkembang pesat yang beroperasi di dalamnya.

Mengapa Internet Exchange Point penting?

Tanpa IXP, lalu lintas dari satu jaringan ke jaringan lain berpotensi bergantung pada jaringan perantara untuk membawa lalu lintas dari sumber ke tujuan. Ini disebut penyedia transit. Dalam beberapa situasi, tidak ada masalah untuk melakukan hal ini: ini adalah seberapa besar arus lalu lintas internet internasional, karena biaya yang mahal untuk mempertahankan koneksi langsung ke setiap-dan-setiap ISP di dunia. Namun, mengandalkan ISP tulang punggung untuk membawa lalu lintas lokal dapat merugikan kinerja, terkadang karena operator tulang punggung mengirimkan data ke jaringan lain di kota yang sama sekali berbeda. Situasi ini dapat mengarah pada apa yang dikenal sebagai tromboning, di mana dalam kasus terburuk, lalu lintas dari satu kota yang ditujukan ke ISP lain di kota yang sama dapat menempuh jarak yang sangat jauh untuk dipertukarkan dan kemudian kembali lagi. CDN dengan kehadiran IXP memiliki keuntungan dalam mengoptimalkan jalur yang dilalui data mengalir di dalam jaringannya, mengurangi jalur yang tidak efisien.

BGP, protokol tulang punggung Internet

Jaringan berbicara satu sama lain menggunakan BGP (Border Gateway Protocol). Protokol ini memungkinkan jaringan untuk dengan rapi memisahkan antara persyaratan internal dan konfigurasi tepi jaringannya. Semua peering di IXP menggunakan BGP.

Baca juga Artikel kami yang membahas tentang Apa itu Peering

Bagaimana penyedia berbagi lalu lintas di berbagai jaringan?

Transit

Perjanjian antara pelanggan dan penyedia upstreamnya. Penyedia transit menyediakan konektivitas penuh kepada pelanggannya ke seluruh Internet. Transit adalah layanan berbayar. Protokol BGP digunakan untuk memungkinkan alamat IP pelanggan diumumkan ke penyedia transit dan selanjutnya ke seluruh Internet global.

Peering

Pengaturan di balik bagaimana jaringan berbagi alamat IP tanpa perantara di antara mereka. Di Internet Exchange Point, sebagian besar tidak ada biaya yang terkait dengan transfer data antar jaringan anggota. Ketika lalu lintas ditransfer secara gratis dari satu jaringan ke jaringan berikutnya, hubungan tersebut disebut peering bebas penyelesaian.

Peering VS Transit Berbayar

Sayangnya untuk beberapa jaringan, mentransfer data tidak selalu tanpa biaya. Misalnya, jaringan besar dengan pangsa pasar yang relatif sama lebih cenderung melakukan peer dengan jaringan besar lainnya tetapi mungkin mengenakan biaya jaringan yang lebih kecil untuk layanan peering. Dalam satu IXP, perusahaan anggota dapat memiliki pengaturan yang berbeda dengan beberapa anggota yang berbeda. Dalam kasus seperti ini, perusahaan dapat mengonfigurasi protokol perutean mereka untuk memastikan bahwa mereka mengoptimalkan untuk mengurangi biaya atau mengurangi latensi menggunakan protokol BGP.

Deepering

Seiring waktu, hubungan dapat berubah, dan terkadang jaringan tidak lagi ingin berbagi interkoneksi gratis. Ketika sebuah jaringan memutuskan untuk mengakhiri pengaturan peering mereka, mereka melalui proses yang disebut deepering. Deepering dapat terjadi karena berbagai alasan seperti ketika satu pihak diuntungkan lebih dari yang lain karena rasio lalu lintas yang buruk, atau ketika jaringan memutuskan untuk mulai menagih uang pihak lain. Proses ini bisa sangat emosional, dan jaringan yang ditolak dapat dengan sengaja mengganggu lalu lintas pihak lain setelah hubungan peering diakhiri.

Pentingnya Peran IXP dalam Lalu Lintas Internet

Lingkungan Datacenter berhasil beroperasi dengan memiliki throughput tinggi, kecepatan tinggi, dan harga rendah. Tanpa peran Internet Exchange Point, kokentivitas Internet pasti akan jauh lebih mahal harganya. Herza.ID bisa memberikan layanan Colocation Murah, VPS Murah dan Dedicated Server Murah dengan Bandwidth yang murah dikarenakan Jaringan Herza.ID sudah terhubung ke banyak Internet Exchange Point di Indonesia. Antara lain adalah IIX, OpenIXP, JKT-IX, CDIX, DCI-IX. BatamIX, dan CloudXchange. Disamping itu, Herza.ID juga mempunya lebih dari 10 mitra peering di seluruh Indonesia & dunia, termasuk Google, Microsoft, Facebook, Akamai, Cloudflare, SEA Group (Shopee & Garena) dan Zenlayer, dan titik kehadiran (PoP) kami dapat mentransfer gabungan lebih dari 100 Gigabyte per detik dan tentunya ini akan terus berkembang seiring perkembangan Datacenter Herza.

Bagaimana IXP menggunakan BGP?

Di seluruh jaringan lokal IXP, berbagai penyedia dapat membuat koneksi satu-ke-satu menggunakan protokol BGP. Protokol ini dibuat untuk memungkinkan jaringan yang berbeda mengumumkan alamat IP mereka satu sama lain ditambah alamat IP yang telah mereka sediakan konektivitas ke hilir (yaitu pelanggan mereka). Setelah dua jaringan menyiapkan sesi BGP, rute masing-masing akan dipertukarkan dan lalu lintas dapat mengalir langsung di antara keduanya.

IXP atau PNI

Dua jaringan mungkin menganggap lalu lintas mereka cukup penting sehingga mereka ingin berpindah dari infrastruktur bersama dari sebuah IXP dan ke interkoneksi khusus antara dua jaringan. PNI (Private Network Interconnect) hanyalah koneksi dark fiber (biasanya dalam satu pusat data, atau gedung) yang secara langsung menghubungkan port di jaringan A dengan port di jaringan B. Pengaturan BGP hampir identik dengan pengaturan peering IXP bersama.

Apa itu Peering?

Kami sering mendapatkan pertanyaan tentang Apa itu Peering. Peering adalah metode yang memungkinkan dua jaringan untuk menghubungkan dan bertukar lalu lintas data secara langsung tanpa harus membayar pihak ketiga untuk membawa lalu lintas di Internet.

Gambaran Umum Tentang Peering

Internet terdiri dari lebih dari 25.000 sistem otonom (ASN) yang merutekan lalu lintas secara independen. Peering sering digunakan sebagai metode di mana sistem ini dapat berinteraksi dan bertukar lalu lintas, memungkinkannya mengalir dari satu pengguna akhir, melalui Internet, ke pengguna akhir lainnya.

Metode ini diperlukan untuk perusahaan yang saling berhubungan, penyedia layanan Internet (ISP), jaringan pengiriman konten (CDN), dan penyedia layanan backbone. Membentuk perjanjian peering dengan jaringan lain dan menghindari keterlibatan pihak ketiga memungkinkan perusahaan untuk:

  1. Biaya transit yang lebih rendah
  2. Mempertahankan kontrol jalur perutean yang lebih besar
  3. Meningkatkan kinerja jaringan secara keseluruhan
  4. Meningkatkanredundansi dengan menggunakan beberapa lokasi
  5. Meningkatkankapasitas bandwidth
  6. Memiliki akses ke dukungan tambahan yang disediakan oleh mitra peering

Jenis Jenis Koneksi Peering

Peering menunjukkan bahwa dua jaringan terhubung, tetapi tidak menunjukkan bagaimana mereka terhubung. Prosesnya dapat dimulai dengan menjalankan sirkuit dari satu fasilitas ke fasilitas lainnya, tetapi metode itu menjadi tidak efisien ketika jaringan membutuhkan banyak peer. Dua jenis peering yang lebih umum dan efisien disebut peering publik dan peering privat.

Public Peering

Public Peering atau Peering publik umumnya dilakukan melalui Internet Exchange Point (IXP). IXP di Indonesia yang kita kenal antara lain adalah IIX, OpenIXP, CDIX, JKT-IX dan lainnya. Di lokasi ini, satu jaringan dapat melakukan peer dengan beberapa jaringan lain. Pengaturan peering perlu dinegosiasikan dengan setiap peer, tetapi tidak ada kabel baru yang perlu dilakukan.

Private Peering

Private Peering atau sering juga disebut sebagai PNI (Private Network Interconnection) terjadi di fasilitas Datacenter di mana dua entitas dengan jaringan terpisah menempatkan router dan menjalankan kabel langsung di antara mereka, jadi metode ini tidak menggunakan penengah Internet Exchange Point seperti pada Public Peering. Metode ini berguna ketika jaringan perlu bertukar lalu lintas dalam jumlah besar yang tidak dapat dapat dilakukan pada koneksi bersama melalui Internet Exchange Point.

Bagaimana Peering Bekerja?

Internet Exchange Point menyediakan satu lokasi untuk semua perangkat keras yang diperlukan untuk menghubungkan beberapa jaringan. Internet Exchange Point memiliki formulir keanggotaan di situs web mereka yang dapat Anda isi untuk mengajukan permohonan tempat di colocation mereka. Jika Anda disetujui, mereka akan menghubungi Anda secara langsung untuk memfasilitasi koneksi fisik Anda ke colocation mereka.

Memiliki koneksi fisik ke IXP tidak berarti Anda secara otomatis memiliki perjanjian peering dengan jaringan lain di sana. Setiap jaringan yang ingin mengadakan perjanjian peering di lokasi ini biasanya memiliki persyaratan operasional dan teknis yang harus Anda penuhi sebelum dapat terhubung dengannya. Sebagian besar perjanjian peering ISP mengharuskan Anda memiliki yang berikut ini:

  1. ASN yang diarahkan secara publik
  2. Memiliki Blok IP Sendiri
  3. Border Router yang mampu menjalankan BGP Session

Setelah Anda disetujui untuk melakukan peer dengan jaringan, Anda harus mengonfigurasi setelan peering router Anda secara manual untuk berbicara dengan ASN tertentu menggunakan Border Gateway Protocol (BGP).

Pentingnya Peering dalam Internet

Lingkungan Datacenter berhasil beroperasi dengan memiliki throughput tinggi, kecepatan tinggi, dan harga rendah. Tanpa peering, Edge Computing dalam lingkup Datacenter mungkin tidak mungkin dilakukan. Lebih banyak mitra peering berarti Edge Computing lebih cepat dan pengiriman konten lebih cepat. Herza.ID, misalnya, memiliki lebih dari 10 mitra peering di seluruh Indonesia & dunia, termasuk Google, Microsoft, Facebook, Akamai, Cloudflare, SEA Group (Shopee & Garena) dan Zenlayer, dan titik kehadiran (PoP) kami dapat mentransfer gabungan lebih dari 100 Gigabyte per detik dan tentunya ini akan terus berkembang seiring perkembangan Datacenter Herza.

Contoh Peering

OpenIXP adalah salah satu IXP (Internet Exchange Point) terbesar di Indonesia. Mereka memiliki lebih dari 1,000 ASN yang terhubung dan dapat memindahkan hampir 1 Terabyte lalu lintas per detik melalui 2 lokasi mereka (Gedung Cyber dan IDC 3D).

Peering ke OpenIXP

Baca juga Artikel kami yang membahas tentang Apa itu IIX dan OpenIXP

Salah satu keuntungan bekerja dengan bursa internet seperti OpenIXP adalah bahwa mereka sering kali memiliki perjanjian multilateral, yang berarti bahwa persyaratan mereka untuk menjadi anggota sesuai dengan sebagian besar persyaratan pelanggan mereka untuk sesama. Ketika Anda disetujui untuk koneksi ke salah satu colocations OpenIXP, Anda terhubung ke server rute yang memberi Anda akses instan ke 80% jaringan yang terhubung.

Apa itu vCPU pada VPS?

Merujuk ke halaman paket VPS Murah kami, calon pelanggan kami sering kali menghubungi kami melalui Online Chat. Dalam 80% kasus, pertanyaan pertama yang sering ditanyakan adalah… Apa itu vCPU? Itu mendorong saya untuk menulis artikel tentang topik ini. Meskipun, matematika vCPU sedikit rumit untuk dipahami, namun kami mencoba mengumpulkan semua informasi yang mungkin dan mencoba menjelaskannya kepada Anda dengan kata-kata yang paling sederhana. Di HyperVisor, CPU fisik sepenuhnya dikontrol oleh Hypervisor itu sendiri. CPU Fisik atau Dedicated ini dibagi menjadi inti CPU Core. Setiap Core dengan sangat aman mendukung 8 virtual prosesor (vCPU). Sekarang, mari kita bahas beberapa istilah teknis terlebih dahulu:

SOKET CPU

Soket mewakili perangkat keras. Mereka disebut sebagai jumlah soket prosesor yang dimiliki motherboard Anda. Soket hanya kapasitas motherboard. Soket bisa kosong. Kekuatan sebenarnya adalah jumlah prosesor yang sebenarnya dipasang pada motherboard.

CPU FISIK / DEDICATED

CPU fisik adalah unit perangkat keras sebenarnya yang dipasang pada soket motherboard Anda.

CORE DEDICATED

Ini adalah prosesor / core fisik aktual dalam chipset CPU fisik Anda (prosesor multi-core). Setiap core fisik bertindak sebagai prosesor terpisah karena memiliki sirkuit dan L1, cache L2 sendiri.

Virtual Processor / vCPU

vCPU adalah entitas yang bergantung pada waktu. Prosesor Virtual bisa dibahasakan sebagai kemungkinan jumlah waktu pemrosesan yang dihabiskan pada CPU. Jika kita menggunakan terminologi teknis; Prosesor Virtual dipetakan ke Logical Processor yang tersedia di komputer fisik dan dijadwalkan oleh perangkat lunak Hypervisor untuk memungkinkan Anda memiliki lebih banyak prosesor virtual daripada Logical Processor Anda. Orang mungkin memiliki kesalahpahaman bahwa 1 vCPU sama dengan 1 Core. Tetapi tidak ada hubungan satu dengan lainnya antara vCPU dan Core dalam perangkat lunak virtualisasi apa pun.

Mari kita coba memahami istilah-istilah ini dengan sebuah Contoh. Di sini, kami mempertimbangkan bahwa satu Core fisik dapat dengan aman mendukung 8 prosesor virtual. Mari kita lihat bagaimana perencanaan ini berjalan:

CPU yang kami perhitungkan adalah Intel Xeon CPU E5-2650 v2

  • Intel Xeon CPU E5-2650 v2 memiliki 8 Core x8 = 64 vCPU.
  • 4 vCPU untuk setiap VM… 64 vCPU / 4 vCPU per VM = 16 VM
  • 2 vCPU untuk setiap VM… 64 vCPU / 2 vCPU per VM = 32 VM
  • 1 vCPU untuk setiap VM… 64 vCPU / 1 vCPU per VM = 64 VM

Sebuah VM bisa menggunakan hingga 4 vCPU menurut lisensi standar ESX host VMware dan bisa sampai 8 vCPU pada edisi Enterprise. Jumlah dari vCPU yang dapat dipakai dalam server kita tergantung pada jumlah beban yang akan ditanggung VM. Jumlah virtual Core yang dapat ditetapkan ke VM dibatasi. Jika Anda pengguna VPS Windows Murah, Windows Server 2008 R2 membatasi jumlah vCPU sebanyak 4 per VM yang diperluas menjadi 64 di Windows Server 2012.

Mudah-mudahan Artikel ini dapat memberikan kita wawasan tambahan mengenai pengertian dari Apa itu vCPU atau Virtual CPU. Jangan lupa bagikan Artikel ini untuk membantu teman teman yang lainnya.

Melindungi Router Mikrotik dari Ransomware

Akhir akhir ini marak kejadian Router Mikrotik di Hack oleh orang-orang yang tidak bertanggung jawab dengan mengunci Boot Loader di Mikrotik Router tersebut sehingga tidak dapat dilakukan reset ataupun netinstall dan melakukan permintaan imbalan untuk membuka kunci Boot Loader Mikrotik tersebut. Hal ini kita sebutkan sebagai Ransomware.

Apa itu Ransomware? Ransomware adalah jenis perangkat lunak berbahaya yang dirancang untuk memblokir akses ke sistem komputer, router atau perangkat dalam sebuah jaringan dan bahkan sebuah file di komputer Anda hingga sejumlah uang dibayarkan. Dalam hal Router Mikrotik, pelaku mengunci Boot Loader Router yang terpengaruh, membuatnya tidak dapat diakses, dan meminta pembayaran tebusan untuk memulihkan akses perangkat tersebut.

Apakah Anda membutuhkan IP Publik untuk Mikrotik atau Server lokal Anda? Atau mungkin Anda mencari solusi Tunneling untuk mengganti nama ISP di Speedtest Anda. VPS Mikrotik CHR Murah dari Herza.ID adalah solusinya.

Nah, maka dari itu, mari kita menyimak beberapa tahapan yang dapat membantu Anda dalam melindungi Router Mikrotik Anda dari Ransomware.

Cara Melindungi Router Mikrotik dari Ransomware

Lakukan Daily Backup

Lakukan backup secara berkala atas konfigurasi router mikrotik Anda untuk menghindari lamanya downtime ketika Router Anda bermasalah. Dengan melakukan backup secara berkala, ketika Router Anda bermasalah, Anda dengan mudah dapat mengganti Router Anda dengan Router cadangan dengan mengimport file konfigurasi yang telah terbackup sebelumnya. Hal ini dapat kita lakukan menggunakan scheduler script untuk membackup ke email.

/system script
add dont-require-permissions=yes name=EmailBackup source=":\
    log info \"Starting Backup Script...\"\r\
    \n:global backupfile ([/system identity get name] . \".backup\")\r\
    \n:if ([/file find name=\$backupfile] != \"\") do={/file rem \$backu\
    pfile}\r\
    \n:delay 2s\r\
    \n/system backup save name=\$backupfile\r\
    \n:log info \"Waiting 7s for backup to complete...\"\r\
    \n:delay 7s\r\
    \n:log info \"Backup being emailed...\"\r\
    \n/tool e-mail send to=\"[email protected]\" subject=([/system ide\
    ntity get name] . \" Backup\") [email protected] user=\"[email protected]\" password=\"passwordemailku\" file=\$backupfile server=smtp.emailku.com\r\
    \n:log info \"Finished Backup Script!\""
/system scheduler
add interval=1d name=EmailBackup on-event=ebackup start-date=\
    mar/04/2019 start-time=01:00:00

Jangan lupa untuk mengganti domain @emailku.com dengan domain ISP atau perusahaan anda, ganti passwordemailku dengan password email anda yang digunakan untuk mengirim email, ganti smtp.emailku.com dengan smtp ISP atau perusahaan anda.

Silahkan baca Panduan Dasar Mikrotik CLI (Command Line Interface), mungkin bermanfaat buat Anda.

Pengamanan Dasar Mikrotik

Selanjutnya, untuk mengamankan Router Mikrotik Anda, sangat disarankan bagi seluruh User Mikrotik untuk melakukan beberapa langkah dasar berikut untuk pengamanan di Router Anda.

Jangan Pernah Menggunakan Port Default Winbox

Selalu untuk merubah port standar winbox dari 8291 menjadi port lainnya, ingat jangan gunakan port 0 sd 1024 karena port tersebut sudah digunakan oleh layanan yang sudah di definisikan secara baku, pakailah port di atas 1024 misalnya menjadi 18291 jangan gunakan port diatas 65535 https://en.wikipedia.org/wiki/Port_(computer_networking)

Caranya, di RouterOS Anda klik IP > SERVICE kemudian akan muncul window IP SERVICE LIST seperti dibawah ini. Double Klik Winbox, kemudian ganti Port sesuai dengan yang Anda inginkan.

Kemudian, layanan-layanan yang Anda tidak butuhkan seperti API, FTP, SSH, Telnet, WWW jika tidak butuhkan sebaiknya di Non Aktifkan dengan cara memilih layanan tersebut kemudian mngklik tombok X pada window IP SERVICE LIST tersebut.

Grouping Interface ke Interface-List

Membuat grouping interface ke dalam interface-list untuk memudahkan dalam pembuatan rule firewall yang akan kita buat.

Pada script berikut saya membuat interface list dengan nama “Upstream” dengan memasukkan interface VLAN dengan nama OpenIXP, CDIX dan ether4 kedalam list Upstream tersebut. Kita bisa memasukan beberapa interface fisik ataupun VLAN ke sebuah list interface.

/interface list
add comment="Interface Upstream" name=Upstream
/interface list member
add interface=ether4 list=Upstream
add interface=OpenIXP list=Upstream
add interface=CDIX list=Upstream
Grouping IP Address sebagai ournetwork

Sekarang kita akan membuat grouping IP Address dan/atau Network Address “ournetwork” yang akan berisi seluruh prefix IP yang Anda gunakan serta IP PTP Upstream Anda.

/ip firewall address-list
add address=103.152.XXX.XXX/23 list=ournetwork
add address=192.168.XXX.XXX/24 list=ournetwork
add address=202.78.XXX.XXX/27 comment=DTP-IIX list=PTP-Upstream
add address=218.100.XXX.XXX/24 comment=OpenIXP list=PTP-Upstream
add address=103.30.XXX.XXX/23 comment=CDIX list=PTP-Upstream
add address=103.225.XXX.XXX/25 comment=CXC list=PTP-Upstream
Buat Firewall Rules & Raw untuk Mengamankan Router Anda

Setelah Interface List dan IP Address telah kita grouping, sekarang kita bisa dengan mudah menggunakan list tersebut kedalam Firewall Rules & Raw yang akan kita gunakan.

/ip firewall filter
add action=add-src-to-address-list address-list="Port_Scanner" \
    address-list-timeout=2w chain=input comment="PORT SCANNER" protocol=tcp \
    psd=21,3s,3,1
add action=add-src-to-address-list address-list="Port_Scanner" \
    address-list-timeout=2w chain=input comment="NMAP FIN Stealth scan" \
    protocol=tcp tcp-flags=fin,!syn,!rst,!psh,!ack,!urg
add action=add-src-to-address-list address-list="Port_Scanner" \
    address-list-timeout=2w chain=input comment="SYN/FIN scan" protocol=tcp \
    tcp-flags=fin,syn
add action=add-src-to-address-list address-list="Port_Scanner" \
    address-list-timeout=2w chain=input comment="SYN/RST scan" protocol=tcp \
    tcp-flags=syn,rst
add action=add-src-to-address-list address-list="Port_Scanner" \
    address-list-timeout=2w chain=input comment="FIN/PSH/URG scan" \
    protocol=tcp tcp-flags=fin,psh,urg,!syn,!rst,!ack
add action=add-src-to-address-list address-list="Port_Scanner" \
    address-list-timeout=2w chain=input comment="ALL/ALL scan" protocol=tcp \
    tcp-flags=fin,syn,rst,psh,ack,urg
add action=accept chain=output comment="FTP BLAACKLIST" content=\
    "530 Login incorrect" dst-limit=1/1m,9,dst-address/1m protocol=tcp
add action=add-dst-to-address-list address-list=ftp_blacklist \
    address-list-timeout=3h chain=output content="530 Login incorrect" \
    protocol=tcp
add action=add-src-to-address-list address-list=ssh_blacklist \
    address-list-timeout=1w3d chain=input comment="SSH BLACKLIST" \
    connection-state=new dst-port=22 protocol=tcp src-address-list=\
    ssh_stage3
add action=add-src-to-address-list address-list=ssh_stage3 \
    address-list-timeout=1m chain=input connection-state=new dst-port=22 \
    protocol=tcp src-address-list=ssh_stage2
add action=add-src-to-address-list address-list=ssh_stage2 \
    address-list-timeout=1m chain=input connection-state=new dst-port=22 \
    protocol=tcp src-address-list=ssh_stage1
add action=add-src-to-address-list address-list=ssh_stage1 \
    address-list-timeout=1m chain=input connection-state=new dst-port=22 \
    protocol=tcp
add action=accept chain=input comment="ACCEPT BGP DARI Upstream" \
    in-interface-list=Upstream log-prefix="bgp  : " protocol=tcp \
    src-address-list=PTP-Upstream
add action=accept chain=input comment="ACCEPT BGP DARI Upstream" \
    dst-address-list=PTP-Upstream in-interface-list=Upstream log-prefix=\
    "bgp  : " protocol=tcp
add action=accept chain=input comment="ACCEPT ICMP" log-prefix="icmp  : " \
    protocol=icmp src-address-list=ournetwork
add action=accept chain=input comment="ACCEPT ICMP" log-prefix="icmp  : " \
    protocol=icmp src-address-list=PTP-Upstream
add action=accept chain=input comment="ACCEPT ALL DARI ROUTER DISTRIBUSI" \
    in-interface-list=!Upstream log-prefix="not Upstream : " \
    src-address-list=ournetwork
add action=accept chain=input comment="ACCEPT ALL DARI ROUTER DISTRIBUSI" \
    dst-address-list=ournetwork in-interface-list=!Upstream log-prefix=\
    "not Upstream : "
add action=add-src-to-address-list address-list=winbox-exploit \
    address-list-timeout=5m chain=forward comment="WINBOX EXPLOIT" \
    dst-port=8291 in-interface-list=Upstream log-prefix="WINBOX EXPLOIT : " \
    protocol=tcp
add action=add-src-to-address-list address-list=proxy-socks-exploit \
    address-list-timeout=5m chain=forward comment="PROXY SOCKS EXPLOIT" \
    dst-port=8000,3128,1080,4145 in-interface-list=Upstream log-prefix=\
    "PROXY SOCKS EXPLOIT : " protocol=tcp

Dari script firewall rules diatas bisa kami jelaskan adalah mengenai akss yang dibolehkan ke Mikrotik RouterOS hanya dari address-list=ournetwork dan PTP-Upstream sedangkan akses dari interface distribusi atau “!Upstream” = bukan Upstream di ALLOW. Serta koneksi BGP via TCP di ALLOW dari dan ke interface “Upstream”

Sedangkan pada IP > FIREWALL > RAW, saya manDROP seluruh aktivitas yang telah ditangkap oleh Firewall Rules yang kami buat diatas seperti SSH BLACKLIST (Percobaan bruteforce ke SSH Router Mikrotik), DROP WINBOX (Seluruh Akses ke Port Winbox Default 8291 akan ditolak demi keamanan) dan juga DROP PORT SCANNER (Seluruh aktivitas Scanning akan diblok oleh Filter Raw ini. Disamping itu, saya juga menangkap dan DROP semua traffic ke yang mengarah ke Port 8000,3128,1080,4145 yang masuk via interface Upstream menuju ke jaringan distribusi yang dikawatirkan digunakan hacker untuk menyerang Mikrotik RouterOS distribusi dan pelanggan di melalui IP->Firewall->Raw

/ip firewall raw
add action=drop chain=prerouting comment="DROP ACTIVE DIRECTORY" dst-port=\
    445 log-prefix="drop 445 : " protocol=tcp
add action=drop chain=prerouting comment="DROP TCPMUX" dst-port=1 \
    log-prefix="drop 445 : " protocol=tcp
add action=drop chain=prerouting comment="SSH BLACKLIST" in-interface-list=\
    Upstream src-address-list=ssh_blacklist
add action=drop chain=prerouting comment="DROP WINBOX" dst-port=8291 \
    in-interface-list=Upstream log-prefix="DROP WINBOX EXPLOIT : " \
    protocol=tcp src-address-list=winbox-exploit
add action=drop chain=prerouting comment="DROP PORT SCANNER" \
    in-interface-list=Upstream log-prefix="DROP PORT SCANER : " \
    src-address-list="port scanners"
add action=drop chain=prerouting comment="DROP PROXY SOCKS" \
    in-interface-list=Upstream log-prefix="DROP PROXY SOCKS : " \
    src-address-list=proxy-socks-exploit
add action=drop chain=prerouting comment="DROP NETBIOS" dst-port=137-139 \
    log-prefix="drop 445 : " protocol=tcp
add action=drop chain=prerouting comment="DROP NETBIOS" dst-port=137-139 \
    log-prefix="drop 445 : " protocol=udp

Penutup

Seluruh Firewall Rules dan Raw diatas adalah bukan bentuk baku yang harus Anda ikuti. Anda harus mengikuti sesuai dengan kebutuhan dan Topologi jaringan Anda. Kemungkinan ada beberapa Rules yang butuh adjustment ataupun revisi untuk disesuaikan dengan kebutuhan jaringan Anda.

Cara Buat VPN All Traffic Di VPS Mikrotik CHR

Dikarenakan banyaknya permintaan Tutorial untuk pembuatan VPN All Traffic pada VPS Mikrotik CHR, maka pada artikel kali ini, kami akan membahas hal tersebut secara tahap demi tahap. Silahkan diperhatikan tahapannya berikut ini.

Mikrotik Cloud Hosted Router atau lebih dikenal dengan nama Mikrotik CHR adalah sebuah router Mikrotik yang dapat di install pada Virtualisasi seperti KVM, VirtualBox, VMware dan lainnya. Fungsinya kurang lebih sama dengan RouterOS pada umumnya. Tetapi lisensi Mikrotik CHR bisa dipindahkan, dan tidak permanen pada suatu storage seperti pada lisensi RouterOS yang biasa. Untuk informasi lengkap mengenai Mikrotik CHR, silahkan membaca Artikel kami tentang Apa itu Mikrotik CHR.

Jika Anda membutuhkan panduan mengenai Mikrotik Command Line Interface, maka silahkan membaca Artikel kami mengenai Panduan Dasar Mikrotik CLI (Command Line Interface).

Konfigurasi Server VPN pada VPS Mikrotik CHR

Pertama-tama, login pada Winbox menggunakan IP / MAC Address Mikrotik CHR Anda dengan username dan password Anda, kemudian pada menu Winbox sebelah kiri, klik INTERFACE.

Pada menu INTERFACE, klik PPTP / L2TP Server (Disesuaikan dengan kebutuhan) untuk Enable service vpn nya di Mikrotik CHR Anda.

Kemudian dilanjutkan dengan membuat IP Pool. Pada menu Winbox pilih IP > POOL

Sekarang kita akan mengkonfigurasi profil VPN. Pada menu utama Winbox Anda, klik PPP > PROFILES > + (Icon Plus untuk menambahkan Profile Baru). Kemudian pilih Local Address sebagai main IP Anda dan Remote Address dari IP Pool yang anda buat sebelumnya.

Sekarang dilanjutkan dengan membuat User dan Password untuk Koneksi VPN Tersebut. Pada menu PPP, pilih tab SECRETS, kemudian masukkan Name dan Password sesuai dengan yang Anda inginkan seperti pada contoh dibawah ini.

Sekarang kita sudah selesai mengkonfigurasi VPN Server pada VPS Mikrotik CHR dan kita akan melanjutkan konfigurasi untuk Client VPS nya.

Konfigurasi Client VPN

Client VPN ini akan dikonfigurasikan pada Router Mikrotik di Rumah atau Kantor Anda yang ingin di koneksikan melalui VPS Mikrotik CHR di Herza.ID.

Pada Winbox Anda, klik INTERFACES pada menu utama. Kemudian buat new interface dengan mengklik Icon Plus (+), lalu pilih vpn client. Pada percobaan kali ini saya memilih L2TP Client.

Pada tab DIAL-OUT, connect to di isi menggunakan IP VPS Mikrotik Anda, user dan password di isi sesuai dengan konfigurasi yang Anda lakukan pada VPN Server sebelumnya, Kemudian klik OK.

Kembali ke Menu Utama Winbox, klik IP > ROUTE dan buat 1 route dengan gateway vpn, dan gunakan VPN pada Routing Mark nya sesuai dengan contoh dibawah.

Lalu kita akan melanjutkan dengan membuat 1 NAT dengan out interface VPN yang sudah kita buat sebelumnya. Pada menu Utama Winbox, klik IP > FIREWALL > NAT kemudian klik Icon Plus (+).

Pada tab ACTION di NAT pilih masquerade. Lalu klik OK.

Konfigurasi Mangle

Setelah mengkonfigurasi VPN Client, kita membutuhkan sebuah rules MANGLE yang akan digunakan untuk menangkap traffic yang ada kemudian dikirimkan ke VPS Mikrotik Anda. Sebelum membuat Rules Mangle, terlebih dahulu kita buat address listnya. Silahkan copy paste perintah berikut pada NEW TERMINAL di Winbox Anda.

/ ip fi ad
add address=10.0.0.0/8 disabled=no list=support
add address=172.16.0.0/12 disabled=no list=support\
add address=192.168.0.0/16 disabled=no list=support

Setelah itu, kemudian buat mangel baru di IP > FIREWALL > MANGLE

Pada Tab ADVANCE

Pada tab ACTION

Sekarang, kita telah selesai membuat VPN All Traffic yang dapat digunakan untuk memforward All Traffic Router Mikrotik Anda ke VPS Mikrotik yang Anda sewa di Herza.ID. Selamat mencoba!

10 Perintah Linux Untuk Memeriksa Jaringan

Sulit untuk menemukan komputer Linux yang tidak terhubung ke jaringan Internet di jaman ini, baik itu server atau workstation. Dari waktu ke waktu menjadi perlu untuk mendiagnosa kesalahan, latency tinggi atau kelambatan dalam jaringan. Pada artikel ini, kami akan membahas 10 perintah Linux yang paling banyak digunakan untuk memeriksa jaringan pada Server Linux Anda. Artikel ini akan sangat berguna bagi Anda para pengguna VPS Murah dan Dedicated Server dari Herza.ID.

Jika Anda masih bingung dalam memilih antara Apa itu VPS Hosting dan Kenapa Memilih Dedicated Server, mungkin Anda dapat membaca Artikel kami tentang Pengertian, Fungsi dan Bahan Pertimbangan Dalam Memilih VPS Murah.

Memeriksa Jaringan Di Linux Dengan Perintah-Perintah Ini

1. ping

Salah satu perintah pertama, yang paling dikenal banyak orang, ketika memeriksa kegagalan jaringan atau terputus-putus. Alat ping akan membantu kami menentukan apakah ada koneksi di jaringan, apakah itu lokal atau Internet.

[[email protected] ~]# ping www.herza.id
PING herza.id (149.129.225.111) 56(84) bytes of data.
64 bytes from 111.225.129.149.herza.id (149.129.225.111): icmp_seq=1 ttl=57 time=2.00 ms
64 bytes from 111.225.129.149.herza.id (149.129.225.111): icmp_seq=2 ttl=57 time=1.74 ms
64 bytes from 111.225.129.149.herza.id (149.129.225.111): icmp_seq=3 ttl=57 time=1.78 ms
64 bytes from 111.225.129.149.herza.id (149.129.225.111): icmp_seq=4 ttl=57 time=1.93 ms
64 bytes from 111.225.129.149.herza.id (149.129.225.111): icmp_seq=5 ttl=57 time=1.80 ms
64 bytes from 111.225.129.149.herza.id (149.129.225.111): icmp_seq=6 ttl=57 time=2.05 ms

2. traceroute

Perintah ini memungkinkan kita untuk melihat lompatan atao hoop yang diperlukan untuk mencapai jaringan tujuan. Dalam hal ini, kita akan melakukan pengecekan traceroute untuk melihat lompatan yang diperlukan untuk mencapai situs web kami. Tes ini dilakukan dari Server intranet kami dengan Linux. Dalam contoh ini, kami membuat traceroute ke situs web kami, www.herza.id.

[[email protected] ~]# traceroute www.herza.id

Tracing route to herza.id [149.129.225.111]
over a maximum of 30 hops:

  1    <1 ms    <1 ms    <1 ms  router.lan [192.168.111.1]
  2     2 ms     2 ms     2 ms  148.subnet125-160-9.speedy.telkom.net.id [125.160.9.148]
  3     1 ms     1 ms     2 ms  157.0.252.180.in-addr.arpa [180.252.0.157]
  4     2 ms     5 ms     2 ms  36.91.230.183
  5     3 ms     2 ms     3 ms  36.67.254.70
  6     3 ms     3 ms     2 ms  189.80.251.116.in-addr.arpa [116.251.80.189]
  7    23 ms    46 ms    54 ms  113.250.16.11.in-addr.arpa [11.16.250.113]
  8     6 ms     3 ms     3 ms  166.202.60.11.in-addr.arpa [11.60.202.166]
  9     2 ms     2 ms     2 ms  111.225.129.149.herza.id [149.129.225.111]

Trace complete.

3. route

Perintah ini memungkinkan kita untuk melihat rute yang digunakan Server Linux kita untuk terhubung ke jaringan, dalam hal ini. Peralatan kami berangkat melalui router 192.168.1.1.

[[email protected] ~]# route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.111.1   0.0.0.0         UG    425    0        0 viifbr0
192.168.111.0   0.0.0.0         255.255.255.0   U     425    0        0 viifbr0

4. dig

Perintah ini memungkinkan kita untuk memverifikasi apakah DNS berfungsi dengan benar, sebelum itu, kita harus memverifikasi DNS yang kita miliki dalam konfigurasi jaringan. Dalam contoh ini, kami ingin melihat alamat IP situs web kami, www.herza.id yang mengembalikan kami ke 149.129.225.111.

[[email protected] ~]# dig www.herza.id

; <<>> DiG 9.11.4-P2-RedHat-9.11.4-16.P2.el7_8.6 <<>> www.herza.id
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 40374
;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;www.herza.id.                  IN      A

;; ANSWER SECTION:
www.herza.id.           300     IN      CNAME   herza.id.
herza.id.               300     IN      A       149.129.225.111

;; Query time: 19 msec
;; SERVER: 100.100.2.136#53(100.100.2.136)
;; WHEN: Sun Jun 21 15:41:13 WIB 2020
;; MSG SIZE  rcvd: 71

5. ethtool

Alat ini adalah pengganti mii-tools. Itu berasal dari CentOS6 dan seterusnya dan memungkinkan untuk melihat apakah kartu jaringan secara fisik terhubung ke jaringan, yaitu. Kita dapat mendiagnosis jika kabel jaringan benar-benar terhubung ke switch.

[[email protected] ~]# ethtool em1
Settings for em1:
        Supported ports: [ TP ]
        Supported link modes:   10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Full
        Supported pause frame use: Symmetric
        Supports auto-negotiation: Yes
        Supported FEC modes: Not reported
        Advertised link modes:  10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Full
        Advertised pause frame use: Symmetric
        Advertised auto-negotiation: Yes
        Advertised FEC modes: Not reported
        Speed: 1000Mb/s
        Duplex: Full
        Port: Twisted Pair
        PHYAD: 1
        Transceiver: internal
        Auto-negotiation: on
        MDI-X: on (auto)
        Supports Wake-on: pumbg
        Wake-on: d
        Current message level: 0x00000007 (7)
                               drv probe link
        Link detected: yes

6. IP ADDR LS

Perintah khusus Linux lainnya yang memungkinkan kami untuk membuat daftar kartu jaringan dan alamat IP masing-masing. Alat ini sangat berguna ketika Anda memiliki beberapa alamat IP yang dikonfigurasi.

[[email protected] ~]# ip addr ls
1: lo: mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: eno1: mtu 1500 qdisc mq master bond0 state UP group default qlen 1000
link/ether 2c:44:fd:7a:14:90 brd ff:ff:ff:ff:ff:ff
3: eno2: mtu 1500 qdisc mq master bond0 state UP group default qlen 1000
link/ether 2c:44:fd:7a:14:90 brd ff:ff:ff:ff:ff:ff
4: eno3: mtu 1500 qdisc mq state DOWN group default qlen 1000
link/ether 2c:44:fd:7a:14:92 brd ff:ff:ff:ff:ff:ff
5: eno4: mtu 1500 qdisc mq state DOWN group default qlen 1000
link/ether 2c:44:fd:7a:14:93 brd ff:ff:ff:ff:ff:ff
6: bond0: mtu 1500 qdisc noqueue master viifbr0 state UP group default qlen 1000
link/ether 2c:44:fd:7a:14:90 brd ff:ff:ff:ff:ff:ff

7. ifconfig

Sama pentingnya dengan yang sebelumnya, ifconfig memungkinkan kita untuk melihat konfigurasi jaringan kartu yang dipasang di server kami. Dalam kasus ini, kami menggunakan Network Bonding untuk menyatukan 2 NIC (eno1 dan eno2) untuk berfungsi sebagai round-robin atau load balancing. Jadi ketika salah satu network tidak berfungsi, jaringan masih tetap terhubung ke switch kami.kartu jaringan lokal atau localhost lo dan kartu jaringan nirkabel yang akan terhubung ke jaringan ditampilkan. Kami sengaja menyoroti kartu yang dipasang dan alamat IP yang ditetapkan.

[[email protected] ~]# ifconfig
bond0: flags=5187<UP,BROADCAST,RUNNING,MASTER,MULTICAST>  mtu 1500
        ether 2c:44:fd:7a:14:90  txqueuelen 1000  (Ethernet)
        RX packets 14951  bytes 11554342 (11.0 MiB)
        RX errors 0  dropped 200  overruns 0  frame 0
        TX packets 8254  bytes 631723 (616.9 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

eno1: flags=6211<UP,BROADCAST,RUNNING,SLAVE,MULTICAST>  mtu 1500
        ether 2c:44:fd:7a:14:90  txqueuelen 1000  (Ethernet)
        RX packets 7488  bytes 5785199 (5.5 MiB)
        RX errors 0  dropped 50  overruns 0  frame 0
        TX packets 4127  bytes 314948 (307.5 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 61

eno2: flags=6211<UP,BROADCAST,RUNNING,SLAVE,MULTICAST>  mtu 1500
        ether 2c:44:fd:7a:14:90  txqueuelen 1000  (Ethernet)
        RX packets 7463  bytes 5769143 (5.5 MiB)
        RX errors 0  dropped 50  overruns 0  frame 0
        TX packets 4127  bytes 316775 (309.3 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 62

eno3: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether 2c:44:fd:7a:14:92  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 61

eno4: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether 2c:44:fd:7a:14:93  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 62

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 13  bytes 1489 (1.4 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 13  bytes 1489 (1.4 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

8. mtr

Salah satu alat favorit kami adalah MTR atau My Traceroute memungkinkan kami melihat lompatan / hoop seperti pada traceroute dan melakukan ping pada masing-masing hoop tersebut. Ini sangat berguna untuk menentukan hoop mana yang memiliki keterlambatan dalam lalu lintas jaringan. Dalam contoh kali ini, kita akan menggunakan opsi “mtr -n -r -c 100” yang berarti sebagai berikut:

  • -n atau –no-dns
    Gunakan opsi ini untuk memaksa mtr untuk menampilkan nomor IP saja dan tidak mencoba untuk menampilkan hostname.
  • -r atau –report
    Opsi ini menempatkan mtr ke mode laporan. Ketika dalam mode ini, mtr akan berjalan untuk jumlah siklus yang ditentukan oleh opsi -c, dan kemudian mencetak statistik dan keluar. Mode ini berguna untuk menghasilkan statistik tentang kualitas jaringan.
  • -c COUNT
    Gunakan opsi ini untuk mengatur jumlah ping yang dikirim untuk menentukan mesin pada jaringan dan keandalan mesin tersebut. Setiap siklus berlangsung satu detik.
[[email protected] ~]# mtr -n -r -c 100 www.herza.id
Start: Sun Jun 21 15:54:39 2020
HOST: faeyza.herza.id             Loss%   Snt   Last   Avg  Best  Wrst StDev
  1.|-- 192.168.111.1              0.0%   100    0.2   0.2   0.2   0.2   0.0
  2.|-- 125.160.9.148              0.0%   100    2.0   3.0   1.2  14.9   2.3
  3.|-- 180.252.0.157              0.0%   100    1.8   3.2   1.4  37.6   5.3
  4.|-- 36.91.230.183              0.0%   100    2.0   2.4   1.5  18.8   1.8
  5.|-- 36.67.254.70               0.0%   100    3.0   3.2   2.2   9.8   1.0
  6.|-- 116.251.80.189             0.0%   100    2.8   2.8   2.0   8.0   0.6
  7.|-- 11.16.250.113              0.0%   100   53.9  34.9   4.4  57.5  18.2
  8.|-- 11.60.202.166              0.0%   100    5.6   4.2   3.2   7.6   0.5
  9.|-- 149.129.225.111            0.0%   100    2.6   2.8   2.3   9.3   0.9

9. nslookup

Alat lain untuk mengetahui alamat IP dari host yang ingin kita jangkau. Dalam hal ini, kami ingin mengetahui IP situs web kami, www.herza.id.

[[email protected] ~]# nslookup herza.id
Server:         1.1.1.1
Address:        1.1.1.1#53

Non-authoritative answer:
Name:   herza.id
Address: 149.129.225.111

10. nmtui

Network Manager Text User Interface (nmtui atau Network Manager berdasarkan pada command line). Ia menggunakan ncurses dan memungkinkan kami untuk dengan mudah mengkonfigurasi dari terminal dan tanpa ketergantungan tambahan. Ini menawarkan User Interface, berdasarkan teks, sehingga pengguna membuat modifikasi tersebut dengan mudah.

Dengan seluruh perintah jaringan yang telah kami bahas diatas, kita akan memiliki kesempatan untuk melakukan manajemen yang jauh lebih mudah dan tepat pada berbagai parameter jaringan di lingkungan Linux. Juga Dengan perintah mtr seperti yang kami sebutkan di atas, kami dapat memiliki kontrol yang lebih sederhana atas keadaan jaringan kami dan memeriksa dengan cara yang jauh lebih sentral dengan aspek-aspek berbeda yang berfokus pada pengoptimalannya.

Htop – Monitor Sistem Linux Yang Lebih Interaktif

Artikel ini adalah kelanjutan dari seri Monitoring Performa Linux Server kami, hari ini kita berbicara tentang alat pemantauan paling populer yang disebut htop, yang baru saja mencapai versi 2.2.0 dan dilengkapi dengan beberapa fitur baru yang keren. Aplikasi Htop akan sangat membantu para Sistem Administrator untuk monitoring proses yang berjalan serta beban dari CPU, RAM, SWAP pada VPS Murah atau Dedicated Server Anda.

Htop adalah aplikasi pemantauan proses realtime yang interaktif untuk sistem Linux / Unix dan juga alternatif dari perintah Top, yang merupakan alat pemantauan proses default yang dilengkapi dengan pra-instalasi pada semua sistem operasi Linux.

Htop Linux Process Monitoring

Htop memiliki banyak fitur ramah pengguna, yang tidak tersedia dengan menggunakan perintah Top, diantaranya adalah:

  • Di htop, Anda dapat menggulir secara vertikal untuk melihat daftar proses lengkap dan gulir secara horizontal untuk melihat baris perintah secara lengkap.
  • Htop dimulai dengan sangat cepat dibandingkan dengan yang Top, karena tidak menunggu untuk mengambil data selama startup.
  • Dalam htop Anda dapat mematikan lebih dari satu proses sekaligus tanpa memasukkan PID mereka.
  • Di htop, Anda tidak perlu lagi memasukkan nomor proses atau nilai prioritas untuk memperbaiki proses.
  • Tekan “e” untuk mencetak set variabel lingkungan untuk suatu proses.
  • Dapat menggunakan mouse untuk memilih item daftar.

Cara Instal Htop di Linux Server

Untuk menginstal Htop versi 2.2.0, Anda harus memiliki Development Tools dan Ncurses diinstal pada sistem Anda, untuk melakukannya jalankan beberapa perintah berikut pada distribusi masing-masing.

Pada RHEL/CentOS – 32-bit OS

-------------- For RHEL/CentOS 6 --------------
# wget http://download.fedoraproject.org/pub/epel/6/i386/epel-release-6-8.noarch.rpm
# rpm -ihv epel-release-6-8.noarch.rpm

-------------- For RHEL/CentOS 5 --------------
# wget http://download.fedoraproject.org/pub/epel/5/i386/epel-release-5-4.noarch.rpm
# rpm -ihv epel-release-5-4.noarch.rpm

Pada RHEL/CentOS – 64-bit OS

-------------- For RHEL/CentOS 8 --------------
# yum install epel-release   [CentOS 8]
# dnf install https://dl.fedoraproject.org/pub/epel/epel-release-latest-8.noarch.rpm  [RHEL 8]

-------------- For RHEL/CentOS 7 --------------
# yum install epel-release

-------------- For RHEL/CentOS 6 --------------
# wget http://download.fedoraproject.org/pub/epel/6/x86_64/epel-release-6-8.noarch.rpm
# rpm -ihv epel-release-6-8.noarch.rpm

-------------- For RHEL/CentOS 5 --------------
# wget http://download.fedoraproject.org/pub/epel/5/x86_64/epel-release-5-4.noarch.rpm
# rpm -ihv epel-release-5-4.noarch.rpm

Setelah repositori EPEL terinstall, Anda dapat menekan perintah yum berikut untuk mengambil dan menginstal paket htop seperti yang ditunjukkan.

# yum install htop

Pada Fedora OS

Pengguna Fedora dapat dengan mudah menginstal htop menggunakan repositori Fedora Extras dengan mengetik:

# yum install htop
# dnf install htop      [On Fedora 22+ releases]

Pada Debian and Ubuntu

Di Debian dan Ubuntu, Anda dapat menginstall htop dengan mengetik:

# sudo apt-get install htop

Cara Menggunakan Htop

Sekarang jalankan alat pemantauan htop dengan menjalankan perintah berikut di terminal.

# htop

Htop memiliki tiga bagian utama

  1. Header, dimana Anda dapat melihat informasi CPU, Memory, Swap dan juga menampilkan proses, load average, and Up-time.
  2. Daftar proses yang diurutkan berdasarkan penggunaan CPU.
  3. Footer menunjukkan berbagai opsi seperti bantuan, setup, filter tree kill, nice, quit, dan lain lain.
Konfigurasi Htop

Tekan F2 atau S untuk menu pengaturan> ada empat kolom yaitu Pengaturan, Kolom Kiri, Kolom Kanan, dan Meter yang Tersedia.

Di sini, Anda dapat mengonfigurasi meter yang dicetak di bagian atas jendela, mengatur berbagai opsi tampilan, memilih di antara pola warna dan memilih kolom mana yang dicetak sesuai urutan.

Ketik tree atau t untuk menampilkan proses tampilan proses dengan seluruh cabangnya.

Tree View pada Htop

Anda dapat merujuk fungsi tombol yang ditampilkan di footer untuk menggunakan aplikasi htop yang interaktif untuk memantau proses yang berjalan di Linux. Namun, kami menyarankan untuk menggunakan tombol karakter atau tombol pintas ketimbang tombol fungsi karena mungkin telah dipetakan dengan beberapa fungsi lain dalam koneksi yang aman.

Jangan lupa untuk membaca Artikel kami lainnya untuk membantu mengelolah Server Linux Anda.

10 Command Line Tools untuk Monitoring Performa Linux Server

Merupakan pekerjaan yang sangat sulit bagi setiap Sistem Administrator atau Network Administrator untuk memantau dan melakukan debugging atas kendala pada Kinerja VPS atau Dedicated Server setiap hari. Setelah menjadi Linux Administrator selama beberapa tahun di industri IT, saya jadi tahu betapa sulitnya memonitor dan menjaga sistem tetap berjalan. Untuk alasan ini, kami telah menyusun daftar 10 alat pemantauan dengan CLI yang sering digunakan yang mungkin berguna untuk setiap Sistem Administrator Linux / Unix. Perintah-perintah ini tersedia dalam semua distro Linux dan dapat bermanfaat untuk memantau dan menemukan penyebab sebenarnya dari masalah kinerja. Daftar perintah yang ditunjukkan di sini sangat cukup bagi Anda untuk memilih salah satu yang cocok untuk skenario pemantauan Anda.

Untuk mengerti mengenai VPS atau Dedicated Server, silahkan baca Artikel kami tentang Apa itu VPS Hosting dan Kenapa Memilih Dedicated Server.

1. Top – Untuk Monitoring Proses di Linux

Perintah “Top” adalah program pemantauan kinerja yang sering digunakan oleh banyak sistem administrator untuk memantau kinerja VPS Murah atau Dedicated Server Linux dan tersedia di banyak sistem operasi seperti Linux / Unix. Perintah top digunakan untuk menampilkan semua proses real-time yang berjalan dan aktif dalam daftar yang diurutkan dan memperbaruinya secara teratur. Ini menampilkan penggunaan CPU, penggunaan memori, Swap Memory, Ukuran Cache, Ukuran Buffer, PID Proses, Pengguna, Perintah dan banyak lagi. Ini juga menunjukkan memori tinggi dan pemanfaatan CPU dari proses yang berjalan. Perintah top sangat berguna bagi sistem administrator untuk memantau dan mengambil tindakan yang benar bila diperlukan. Mari kita lihat perintah top dalam tampilan di Terminal SSH.

[[email protected] ~]# top

2. VmStat – Menampilkan Statistik Virtual Memory

Perintah Linux VmStat digunakan untuk menampilkan statistik memori virtual, kernerl threads, disk, proses sistem, blok I/O, interupsi, aktivitas CPU dan banyak lagi. Secara default, perintah vmstat tidak tersedia di sistem Linux, Anda perlu menginstal paket yang disebut sysstat yang mencakup program vmstat. Penggunaan umum format perintah adalah.

[[email protected] ~]# vmstat
procs -----------memory---------- ---swap-- -----io---- -system-- ------cpu-----
 r  b   swpd   free   buff  cache   si   so    bi    bo   in   cs us sy id wa st
 0  0      0 160205056   2124 422484    0    0    40     6   68  101  1  0 99  0  0

3. Lsof – Daftar File yang Terbuka

Perintah Lsof digunakan di banyak sistem seperti Linux / Unix yang digunakan untuk menampilkan daftar semua file yang terbuka dan prosesnya. File yang terbuka termasuk file disk, soket jaringan, pipa, perangkat dan proses. Salah satu alasan utama untuk menggunakan perintah ini adalah ketika disk tidak dapat di-unmount dan menampilkan kesalahan bahwa file sedang digunakan atau dibuka. Dengan perintah ini Anda dapat dengan mudah mengidentifikasi file mana yang digunakan. Format yang paling umum untuk perintah ini adalah.

[[email protected] ~]# lsof

COMMAND     PID      USER   FD      TYPE     DEVICE     SIZE       NODE NAME
init          1      root  cwd       DIR      104,2     4096          2 /
init          1      root  rtd       DIR      104,2     4096          2 /
init          1      root  txt       REG      104,2    38652   17710339 /sbin/init
init          1      root  mem       REG      104,2   129900     196453 /lib/ld-2.5.so
init          1      root  mem       REG      104,2  1693812     196454 /lib/libc-2.5.so
init          1      root  mem       REG      104,2    20668     196479 /lib/libdl-2.5.so
init          1      root  mem       REG      104,2   245376     196419 /lib/libsepol.so.1
init          1      root  mem       REG      104,2    93508     196431 /lib/libselinux.so.1
init          1      root   10u     FIFO       0,17                 953 /dev/initctl

4. Tcpdump – Analisa Paket Jaringan

Tcpdump salah satu penganalisa paket jaringan berbasis CLI atau program sniffer paket yang paling banyak digunakan yang digunakan menangkap atau memfilter paket TCP/IP yang diterima atau ditransfer pada interface tertentu melalui jaringan. Ini juga menyediakan opsi untuk menyimpan paket yang diambil dalam file untuk analisis nanti. Tcpdump hampir tersedia di semua distribusi Linux utama.

[[email protected] ~]# tcpdump -i bond0
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on bond0, link-type EN10MB (Ethernet), capture size 262144 bytes
21:27:22.123753 IP faeyza.herza.id.8492 > 192.168.111.190.57182: Flags [P.], seq 2011851315:2011851503, ack 2285624019, win 313, length 188
21:27:22.124601 IP faeyza.herza.id.47194 > one.one.one.one.domain: 57506+ PTR? 190.111.168.192.in-addr.arpa. (46)
21:27:22.165263 IP 192.168.111.190.57182 > faeyza.herza.id.8492: Flags [.], ack 188, win 8207, length 0
21:27:22.492830 ARP, Request who-has 192.168.111.52 tell gateway, length 46
21:27:22.493065 ARP, Reply 192.168.111.52 is-at 00:16:3e:07:a3:14 (oui Unknown), length 28
21:27:22.732856 ARP, Request who-has faeyza.herza.id tell gateway, length 46
21:27:22.732884 ARP, Reply faeyza.herza.id is-at 2c:44:fd:7a:14:90 (oui Unknown), length 28
21:27:22.856754 ARP, Request who-has gateway tell 192.168.111.52, length 28
21:27:22.856848 ARP, Reply gateway is-at 74:4d:28:5c:4e:fd (oui Unknown), length 46
21:27:22.957364 ARP, Request who-has gateway tell 192.168.111.190, length 46
21:27:23.418149 STP 802.1w, Rapid STP, Flags [Learn, Forward], bridge-id 8000.74:4d:28:5c:4e:fd.8001, length 43
21:27:23.585423 IP one.one.one.one.domain > faeyza.herza.id.47194: 57506 1/1/0 A 36.86.63.182 (139)
21:27:23.587798 IP faeyza.herza.id.40443 > one.one.one.one.domain: 27688+ PTR? 188.111.168.192.in-addr.arpa. (46)
21:27:23.696104 IP 192.168.111.217.53563 > 239.255.255.250.ssdp: UDP, length 125

15 packets captured
52 packets received by filter
0 packets dropped by kernel
4 packets dropped by interface

5. Netstat – Statistik Network

Netstat adalah alat perintah untuk memantau statistik paket jaringan yang masuk dan keluar serta statistik interface itu sendiri. Ini adalah alat yang sangat berguna bagi setiap sistem administrator untuk memantau kinerja jaringan dan memecahkan masalah terkait jaringan.

[[email protected] ~]# netstat -a | more

Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address               Foreign Address             State
tcp        0      0 *:mysql                     *:*                         LISTEN
tcp        0      0 *:sunrpc                    *:*                         LISTEN
tcp        0      0 *:realm-rusd                *:*                         LISTEN
tcp        0      0 *:ftp                       *:*                         LISTEN
tcp        0      0 localhost.localdomain:ipp   *:*                         LISTEN
tcp        0      0 localhost.localdomain:smtp  *:*                         LISTEN
tcp        0      0 localhost.localdomain:smtp  localhost.localdomain:42709 TIME_WAIT
tcp        0      0 localhost.localdomain:smtp  localhost.localdomain:42710 TIME_WAIT
tcp        0      0 *:http                      *:*                         LISTEN
tcp        0      0 *:ssh                       *:*                         LISTEN
tcp        0      0 *:https                     *:*                         LISTEN

6. Htop – Pemantauan Proses Linux

Htop adalah alat pemantauan proses Linux interaktif dan real time yang jauh lebih maju. Ini sangat mirip dengan perintah top Linux tetapi memiliki beberapa fitur yang kaya seperti interface yang user-friendly untuk mengelola proses, tombol shortcut, tampilan vertikal dan horizontal dari proses dan banyak lagi. Htop adalah alat pihak ketiga dan tidak termasuk dalam sistem Linux, Anda harus menginstalnya menggunakan alat pengelola paket YUM. Untuk informasi lebih lanjut tentang instalasi, baca artikel kami di bawah ini.

[[email protected] ~]# htop
Pemantauan Proses Linux dengan Htop

Untuk instalasi Htop, baca: Instal Htop (Linux Process Monitoring) di Linux

7. Iotop – Monitor Linux Disk I/O

Iotop juga sangat mirip dengan perintah Top dan program Htop, tetapi memiliki fungsi akuntansi untuk memantau dan menampilkan waktu nyata I/O Disk dan proses. Alat ini sangat berguna untuk menemukan proses yang tepat dan proses pembacaan atau penulisan disk yang digunakan.

[[email protected] ~]# iotop
Monitor Linux Disk I/O

8. Iostat – Input/Output Statistics

IoStat adalah alat sederhana yang akan mengumpulkan dan menunjukkan statistik sistem input dan output penyimpanan perangkat. Alat ini sering digunakan untuk melacak masalah kinerja perangkat penyimpanan termasuk perangkat, disk lokal, disk jarak jauh seperti NFS.

[[email protected] ~]# iostat
Linux 3.10.0-1062.12.1.vz7.131.10 (jakarta.herza.id)    06/18/2020      _x86_64_        (40 CPU)

avg-cpu:  %user   %nice %system %iowait  %steal   %idle
          18.08    0.00    8.83    0.19    0.00   72.90

Device:            tps    kB_read/s    kB_wrtn/s    kB_read    kB_wrtn
sda             361.86      2677.22      4201.82 13940722347 21879529034
dm-0             80.45       166.08       546.61  864821314 2846308241
dm-1            298.36      2437.17      3326.29 12690704790 17320495805
dm-2              1.35        11.81       298.35   61505561 1553531436
ploop32696        4.56         3.51        28.74   18290730  149658641
ploop15306        8.87         5.11        40.70   26616882  211943321
ploop20652        5.97         7.15       150.44   37257207  783382093
ploop51400        0.05         0.09         0.19     487960    1013405
ploop41804       23.46         2.63       242.41   13706706 1262256976
ploop42553        7.34         1.47        31.97    7634166  166483344
ploop34082        3.68        25.17        30.01  131060599  156259387

9. IPTraf – Real Time IP LAN Monitoring

IPTraf adalah utilitas pemantauan real time network (IP LAN) berbasis konsol sumber untuk Linux. Ini mengumpulkan berbagai informasi seperti monitor lalu lintas IP yang melewati jaringan, termasuk informasi flag TCP, rincian ICMP, gangguan traffic TCP / UDP, paket koneksi TCP dan jumlah byne. Ini juga mengumpulkan informasi statistik antarmuka umum dan yang disembunyikan dari TCP, UDP, IP, ICMP, non-IP, kesalahan checksum IP, aktivitas antarmuka dll.

[[email protected] ~]# iptraf-ng
IPTraf

10. Psacct or Acct – Monitor Aktivitas Pengguna

Psacct atau Acct sangat berguna untuk memonitor setiap aktivitas pengguna pada sistem. Kedua daemon berjalan di latar belakang dan terus mengawasi aktivitas keseluruhan masing-masing pengguna pada sistem dan juga sumber daya apa yang dikonsumsi oleh mereka.

Alat-alat ini sangat berguna bagi sistem administrator untuk melacak setiap aktivitas pengguna seperti apa yang mereka lakukan, perintah apa yang mereka keluarkan, berapa banyak sumber daya yang digunakan oleh mereka, berapa lama mereka aktif pada sistem dll.

Untuk instalasi dan contoh penggunaan perintah, baca artikel di Monitor Aktivitas Pengguna dengan psacct atau acct

Panduan Dasar Mikrotik CLI (Command Line Interface)

Jika Anda adalah pengguna VPS Mikrotik dari Herza.ID, maka Panduan Dasar Mikrotik CLI ini akan sangat berguna untuk melakukan maintenance melalui VNC jika Anda tidak dapat mengakses Winbox melalui Internet.

Kita dapat menggunakan beberapa cara untuk mengakses Mikrotik CHR, yaitu melalui Web Console, Winbox GUI, SSH dan beberapa layanan lainnya yang harus diakses dengan koneksi Internet. Tetapi, bagaimana jika terjadi kesalahan dalam konfigurasi Mikrotrik CHR Anda, dan mengakibatkan, VPS Mikrotik Anda tidak dapat diakses melalui Internet. Maka satu satunya cara adalah dengan mengakses VPS Mikrotik Anda melalui VNC pada Panel VPS Anda.

Baca juga Artikel kami tentang Cara Menginstall Mikrotik CHR di VPS.

Mengkonfigurasi Mikrotik CHR menggunakan perintah CLI tentunya lebih menantang daripada akses melalui GUI seperti Winbox dan Browser. Karena minimum kita harus menguasai logika susunan perintah Mikrotik itu sendiri. Dan mengkonfigurasi Mikrotik menggunakan CLI mempunyai beberapa kelebihan, diantaranya untuk mengakses Mikrotik bisa dengan menggunakan telnet, ssh, kabel serial, menu terminal pada winbox atau pada tutorial kali ini, kita akan mengakses Mikrotik menggunakan VNC melalui Panel VPS.

Akses Mikrotik CHR melalui VNC

1. Login ke Clientarea dan klik pada menu Layanan > Layanan Saya. Pada Halaman tersebut, silahkan Klik Layanan VPS Mikrotik Anda. Maka akan muncul menu seperti dibawah ini.

Akses Menu VNC pada Panel VPS Anda

2. Klik menu VNC pada Panel VPS Anda, kemudian dilanjutkan dengan mengklik Launch HTML 5 VNC Client seperti pada gambawah dibawah ini.

Akses VNC pada VPS Mikrotik Anda

3. Setelah itu, maka Virtual Console akan terbuka melalui Port VNC (Virtual Network Computing).

Tampilan Default pada VNC

4. Silahkan Login dengan memasukkan Username dan Password Anda. Maka Anda akan login ke Terminal CLI Mikrotik CHR Anda.

Login ke Terminal CLI Mikrotik

5. Hal yang pertama kita lakukan, jika terjadi kesalahan konfigurasi pada Mikrotik CHR Anda, kita akan melakukan Reset ke Default setting dengan memasukkan perintah berikut.

/system reset-configuration
Reset Mikrotik CHR

Konfirmasi akan diminta untuk melakukan Reset, dan tekan y kemudian Enter. Maka sekarang Mikrotik akan mereset ke konfigurasi default.

6. Masukkan username default Mikrotik yaitu admin dan password dikosongkan saja kemudian tekan Enter.

7. Setelah login ke Terminal CLI Mikrotik CHR, yang pertama kita lakukan adalah mengeset nama Mikrotik CHR Anda dan Timezone.

/system identify set name=Herza
/system clock
set time-zone-autodetect=no
set time-zoe-name=Asia/Jakarta
/system clock print
Konfigurasi Awal Mikrotik CLI

8. Setelah itu, kita akan menginput IP VPS Mikrotik Anda agar dapat terhubung ke Internet. IP ini bisa Anda dapatkan dengan menghubungi Technical Support.

/ip address
add address=192.168.1.10/24 interface=ether1
/ip route add gateway=192.168.1.1
/ip route print
Setelah IP terinput, maka kita bisa melihat konfigurasi IP seperti diatas

9. Jika Anda pengguna VPS Tunneling dan melakukan Instalasi Mikrotik CHR sendiri, maka kemungkinan besar Anda tidak dapat mengakses Winbox Anda secara langsung. Dikarenakan Port Winbox default 8291 telah kami Blokir Akses nya dari luar untuk menghindari Brute Force bagi User yang lupa mengganti Port Default Winbox mereka.

Untuk awal, masukkan perintah berikut untuk memeriksa Port Service yang terbuka di Mikrotik CHR Anda.

/ip service print

Pada tampilan diatas, kita bisa melihat bahwa Port Winbox masih menggunakan Port standar yaitu 8291. Nah, mari kita lanjutkan perintah berikut untuk mengganti Port Winbox Anda.

/ip service edit winbox port

Maka, Anda akan melihat tampilan seperti diatas. Silahkan rubah port tersebut sesuai dengan port yang ingin Anda gunakan. Ingat jangan gunakan port 0 sd 1024 karena port tersebut sudah digunakan oleh layanan yang sudah di definisikan secara baku, pakailah port di atas 1024 misalnya menjadi 18291 jangan gunakan port diatas 65535 https://en.wikipedia.org/wiki/Port_(computer_networking)

Setelah itu, tekan tombol CTRL O pada keyboard Anda untuk menyimpan dan keluar dari file editor. Maka, sekarang Port Winbox Anda telah berubah.

10. Sekarang VPS Mikrotik Anda dapat diakses melalui Winbox

Demikianlah beberapa setingan dasar Mikrotik yang menggunakan Perintah Dasar CLI – command line interface Mikrotik yang telah kita buat, semoga ada manfaatnya. Jangan lupa membaca Konfigurasi Dasar untuk Mengamankan Router Mikrotik Anda.